phosphor-logging: Fix python dependencies

Make the python dependencies work for both python2 and python3, and add
a missing one.

Signed-off-by: Matt Spinler <spinler@us.ibm.com>
Change-Id: I84ad06c5eabc185bb9bb7a9537bec2f8fef80cbc
diff --git a/recipes-phosphor/logging/phosphor-logging_git.bb b/recipes-phosphor/logging/phosphor-logging_git.bb
index b8210ce..6d95406 100644
--- a/recipes-phosphor/logging/phosphor-logging_git.bb
+++ b/recipes-phosphor/logging/phosphor-logging_git.bb
@@ -15,8 +15,9 @@
 
 DEPENDS += "autoconf-archive-native"
 DEPENDS += "systemd"
-DEPENDS += "python-mako-native"
-DEPENDS += "python-pyyaml-native"
+DEPENDS += "${PYTHON_PN}-mako-native"
+DEPENDS += "${PYTHON_PN}-pyyaml-native"
+DEPENDS += "${PYTHON_PN}-native"
 DEPENDS += "sdbusplus sdbusplus-native"
 DEPENDS += "phosphor-dbus-interfaces phosphor-dbus-interfaces-native"
 DEPENDS += "virtual/phosphor-logging-callouts"