Add stub for phosphor-chassis-cooling-type

Add a stub recipe for this package under development.  Add the libev
package to all images via runtime dependency.

Change-Id: I59ed1a556f08979a70d506d38a9bf267c3e9a220
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/common/recipes-phosphor/fans/phosphor-fan-presence.bb b/common/recipes-phosphor/fans/phosphor-fan-presence.bb
index 62b680a..a064cf1 100644
--- a/common/recipes-phosphor/fans/phosphor-fan-presence.bb
+++ b/common/recipes-phosphor/fans/phosphor-fan-presence.bb
@@ -22,12 +22,18 @@
     ${PN}-tach \
 "
 PACKAGES_remove = "${PN}"
-PACKAGES += "${FAN_PRESENCE_PACKAGES}"
+PACKAGES += "${FAN_PRESENCE_PACKAGES} phosphor-chassis-cooling-type"
+
+# Remove when this package has content
+ALLOW_EMPTY_phosphor-chassis-cooling-type = "1"
+
 SYSTEMD_PACKAGES = "${FAN_PRESENCE_PACKAGES}"
-RDEPENDS_${PN}-dev = "${FAN_PRESENCE_PACKAGES}"
+RDEPENDS_${PN}-dev = "${FAN_PRESENCE_PACKAGES} phosphor-chassis-cooling-type"
 
 RDEPENDS_${PN}-tach += "sdbusplus"
 
+RDEPENDS_phosphor-chassis-cooling-type += "libevdev"
+
 # Needed to install into the obmc-chassis-start target
 TMPL = "phosphor-fan-presence-tach@.service"
 INSTFMT = "phosphor-fan-presence-tach@{0}.service"