phosphor-logging: switch to non-native YAML providers

Move phosphor-logging to use the non-native YAML providers included
with the packagegroup-obmc-yaml-providers instead of the native
structure provided by phosphor-logging-error-logs-native and
phosphor-dbus-interfaces-native.

Signed-off-by: Patrick Williams <patrick@stwcx.xyz>
Change-Id: I701debd6a65c052f380fb7a57314fe2562137b1f
diff --git a/recipes-phosphor/logging/phosphor-logging_git.bb b/recipes-phosphor/logging/phosphor-logging_git.bb
index 7599f08..155e1ef 100644
--- a/recipes-phosphor/logging/phosphor-logging_git.bb
+++ b/recipes-phosphor/logging/phosphor-logging_git.bb
@@ -20,12 +20,11 @@
 DEPENDS += "${PYTHON_PN}-native"
 DEPENDS += "${PYTHON_PN}-sdbus++-native"
 DEPENDS += "sdbusplus"
-DEPENDS += "phosphor-dbus-interfaces phosphor-dbus-interfaces-native"
+DEPENDS += "phosphor-dbus-interfaces"
 DEPENDS += "virtual/phosphor-logging-callouts"
-DEPENDS += "phosphor-logging-error-logs-native"
-DEPENDS += "phosphor-logging-native"
 DEPENDS += "libcereal"
 DEPENDS += "sdeventplus"
+DEPENDS_append_class-target = " packagegroup-obmc-yaml-providers"
 
 PACKAGE_BEFORE_PN = "${PN}-test"
 FILES_${PN}-test = "${bindir}/*-test"
@@ -109,7 +108,7 @@
 PACKAGECONFIG_remove_class-target = "install_scripts"
 
 EXTRA_OECONF = " \
-        YAML_DIR=${STAGING_DIR_NATIVE}${yaml_dir} \
+        YAML_DIR=${STAGING_DIR_TARGET}${yaml_dir} \
         CALLOUTS_YAML=${STAGING_DIR_NATIVE}${callouts_datadir}/callouts.yaml \
         "