systemd: Add journald-dbus to PACKAGECONFIG

We carry a systemd patch that adds a new systemd configure option
--enable-journald-dbus.  Add it to PACKAGECONFIG and select it.

Previously the patch selected the option by default.

Add new files that are installed by the patch to FILES_${PN} to
avoid unpackaged files errors from bitbake due to upstream systemd
recipe changes in Rocko.

Tested: Built and verified witherspoon and palmetto images
Change-Id: Iaf72c2b039706287a00126035eafe2f8631ca473
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/common/recipes-core/systemd/systemd_%.bbappend b/common/recipes-core/systemd/systemd_%.bbappend
index a18d673..3b8a8d9 100644
--- a/common/recipes-core/systemd/systemd_%.bbappend
+++ b/common/recipes-core/systemd/systemd_%.bbappend
@@ -1,7 +1,7 @@
 FILES_${PN}-catalog-extralocales = \
             "${exec_prefix}/lib/systemd/catalog/*.*.catalog"
 PACKAGES =+ "${PN}-catalog-extralocales"
-PACKAGECONFIG_append = " networkd coredump"
+PACKAGECONFIG_append = " networkd coredump journald-dbus"
 PACKAGECONFIG_remove = "machined hibernate ldconfig binfmt backlight localed \
                         quotacheck kdbus ima smack polkit logind bootchart utmp \
                         manpages"
@@ -16,6 +16,11 @@
 #https://github.com/openbmc/openbmc/issues/2016
 SRC_URI += "file://0005-dont-return-error-if-unable-to-create-network-namespace.patch"
 SRC_URI += "file://0006-journal-Create-journald-dbus-object.patch"
+
+# Extra configuration for journald-dbus patch
+PACKAGECONFIG[journald-dbus] = "--enable-journald-dbus,--disable-journald-dbus"
+FILES_${PN} += "${datadir}/dbus-1/system.d/org.freedesktop.journal1.conf"
+
 SRC_URI += "file://0007-journal-Add-Synchronize-dbus-method.patch"
 SRC_URI += "${@mf_enabled(d, 'obmc-ubi-fs', 'file://software.conf')}"
 SRC_URI += "file://0008-man-update-machine-id-5-with-a-note-about-privacy-46.patch"