systemd: Use systemd_unitdir

Somewhere between systemd 234 and 237 the install process stopped making
/usr/lib/systemd/network for us.  When we move to Yocto 2.5 this will
result in an install failure.

bitbake.conf provides a variable for /lib/systemd.  Use it, as it's the
correct location for these configuration/unit files anyhow.

Tested: Booted QEMU witherspoon image to shell
Change-Id: Ia863473539378ef07f652ae3820b9c22ce5f6900
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/common/recipes-core/systemd/systemd_%.bbappend b/common/recipes-core/systemd/systemd_%.bbappend
index 471fd55..539c2d9 100644
--- a/common/recipes-core/systemd/systemd_%.bbappend
+++ b/common/recipes-core/systemd/systemd_%.bbappend
@@ -22,14 +22,14 @@
 SRC_URI += "file://0002-core-Add-WatchdogDevice-config-option-and-implement-.patch"
 
 RRECOMMENDS_${PN} += "obmc-targets"
-FILES_${PN} += "${libdir}/systemd/network/default.network"
-FILES_${PN} += "${libdir}/systemd/system.conf.d/service-restart-policy.conf"
+FILES_${PN} += "${systemd_unitdir}/network/default.network"
+FILES_${PN} += "${systemd_unitdir}/system.conf.d/service-restart-policy.conf"
 
 EXTRA_OECONF += " --disable-hwdb"
 
 do_install_append() {
-        install -m 644 ${WORKDIR}/default.network ${D}${libdir}/systemd/network/
-        install -m 644 -D ${WORKDIR}/service-restart-policy.conf ${D}${libdir}/systemd/system.conf.d/service-restart-policy.conf
+        install -m 644 ${WORKDIR}/default.network ${D}${systemd_unitdir}/network/
+        install -m 644 -D ${WORKDIR}/service-restart-policy.conf ${D}${systemd_unitdir}/system.conf.d/service-restart-policy.conf
 }
 
 do_install_append_df-obmc-ubi-fs() {