Example D-Bus service implementation

Provided an example service implementation in obmc-phosphor-qemu
diff --git a/classes/obmc-phosphor-dbus-service.bbclass b/classes/obmc-phosphor-dbus-service.bbclass
new file mode 100644
index 0000000..9e757bc
--- /dev/null
+++ b/classes/obmc-phosphor-dbus-service.bbclass
@@ -0,0 +1,17 @@
+# Common code for applications providing a D-Bus service.
+
+# Class users should define DBUS_SERVICES prior to including.
+
+python() {
+        services = d.getVar('DBUS_SERVICES', True).split()
+        uris = " ".join( [ 'file://' + s + '.conf' for s in services ] )
+        d.appendVar('SRC_URI', uris)
+}
+
+do_install_append() {
+        # install the service configuration files
+        install -d ${D}${sysconfdir}/dbus-1/system.d
+        for s in ${DBUS_SERVICES}; do
+                install ${WORKDIR}/$s.conf ${D}${sysconfdir}/dbus-1/system.d/$s.conf
+        done
+}