meta-phosphor: Fix SYSTEMD_PAGER export
The shell used to execute the bitbake scripts doesn't support `-e` for
for the echo builtin. This triggers an error upon login:
login: root
Password:
-sh: -e: command not found
root@machine#
Split the workaround into two separate `echo` invocations.
Change-Id: Ic1b59041057d240a880cbf47c459fd364724c7b7
Signed-off-by: Andrew Jeffery <andrew@aj.id.au>
diff --git a/classes/obmc-phosphor-image.bbclass b/classes/obmc-phosphor-image.bbclass
index 4575f5b..8ce0acd 100644
--- a/classes/obmc-phosphor-image.bbclass
+++ b/classes/obmc-phosphor-image.bbclass
@@ -108,7 +108,8 @@
# Disable the pager to prevent systemd injecting control characters into the
# output stream that are not interpreted by busybox tools.
disable_systemd_pager() {
- echo -e "SYSTEMD_PAGER=\nexport SYSTEMD_PAGER" >> ${IMAGE_ROOTFS}${sysconfdir}/profile
+ echo "SYSTEMD_PAGER=" >> ${IMAGE_ROOTFS}${sysconfdir}/profile
+ echo "export SYSTEMD_PAGER" >> ${IMAGE_ROOTFS}${sysconfdir}/profile
}
ROOTFS_POSTPROCESS_COMMAND += "disable_systemd_pager ; "