classes: prepare some classes for native

Enable native recipes to inherit the following classes:
  skeleton-python
  skeleton-sdbus
  skeleton-gdbus
  dbus-dir
  obmc-phosphor-dbus-service

Change-Id: I1d79ffc38792dd48016f09119fc8ace46a304a4b
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/classes/skeleton-python.bbclass b/classes/skeleton-python.bbclass
index 5464e2d..83fef54 100644
--- a/classes/skeleton-python.bbclass
+++ b/classes/skeleton-python.bbclass
@@ -1,5 +1,14 @@
-inherit skeleton
-inherit allarch
 inherit setuptools
 
-DEPENDS += "python"
+do_compile_class-native() {
+    :
+}
+
+do_install_class-native() {
+    :
+}
+
+DEPENDS_append_class-target = " python"
+
+inherit skeleton
+inherit allarch