Fix broken SDK build

The SDK build was failing on installing nlohmann-json, with the error :
nlohmann-json-dev-3.0.1+git0+ce1dccf347-r0 conflicts with nlohmann-json
= 3.0.1+git0+ce1dccf347-r0.

The nlohmann-json package is header-only. So apart from the -dev
package, the rest would be empty. In general the package foo-dev has an
implicit dependency on foo, but yocto will not allow empty packages to
be installed. Add a change to allow installation of the empty base
package in this case. This will satisfy the dependency requirement of
the -dev package.

Change-Id: I8cf0814e83be1c298e26741310e6d8ecdd32c399
Signed-off-by: Deepak Kodihalli <dkodihal@in.ibm.com>
diff --git a/common/recipes-support/nlohmann-json/nlohmann-json_git.bb b/common/recipes-support/nlohmann-json/nlohmann-json_git.bb
index adeee60..57a0bad 100644
--- a/common/recipes-support/nlohmann-json/nlohmann-json_git.bb
+++ b/common/recipes-support/nlohmann-json/nlohmann-json_git.bb
@@ -5,6 +5,8 @@
 
 SRC_URI = "git://github.com/nlohmann/json.git"
 
+ALLOW_EMPTY_${PN} = "1"
+
 PV = "3.0.1+git${SRCPV}"
 
 SRCREV = "ce1dccf347faf6beb2cdf06b788c01cc24e4c6ce"