phosphor-power: Add phosphor-regulators-monitor services

Add the phosphor-regulators monitor services that perform method calls
to phosphor-regulators to enable or disable monitoring of the regulators.
The enable service should be started after power sequencing begins during a
poweron and the disable service startsp immediately at a poweroff to
halt monitoring

Tested:
    Monitoring started after power sequencing services and the chassis
is on
    Monitoring disabled immediately at poweroff

Change-Id: I17f47684bc6ba573e809816825d5eee2f0e3f972
Signed-off-by: Matthew Barth <msbarth@us.ibm.com>
diff --git a/recipes-phosphor/power/phosphor-power_git.bb b/recipes-phosphor/power/phosphor-power_git.bb
index b7bcfd3..cf853d2 100644
--- a/recipes-phosphor/power/phosphor-power_git.bb
+++ b/recipes-phosphor/power/phosphor-power_git.bb
@@ -49,11 +49,13 @@
 PSU_MONITOR_SVC = "phosphor-psu-monitor.service"
 REGS_SVC = "phosphor-regulators.service"
 REGS_CONF_SVC = "phosphor-regulators-config.service"
+REGS_MON_ENA_SVC = "phosphor-regulators-monitor-enable.service"
+REGS_MON_DIS_SVC = "phosphor-regulators-monitor-disable.service"
 
 SYSTEMD_SERVICE_${PN}-sequencer = "${SEQ_MONITOR_SVC} ${SEQ_PGOOD_SVC}"
 SYSTEMD_SERVICE_${PN}-monitor = "${PSU_MONITOR_TMPL}"
 SYSTEMD_SERVICE_${PN}-psu-monitor = "${PSU_MONITOR_SVC}"
-SYSTEMD_SERVICE_${PN}-regulators = "${REGS_SVC} ${REGS_CONF_SVC}"
+SYSTEMD_SERVICE_${PN}-regulators = "${REGS_SVC} ${REGS_CONF_SVC} ${REGS_MON_ENA_SVC} ${REGS_MON_DIS_SVC}"
 
 
 # TODO: cold-redundancy is not installed in the repo yet