Pull rsyslog into image

The intent is to use rsyslog for streaming journal logs off of the BMC.

Since this is the only intent (i.e at the moment there's no requirement
to employ rsyslog for local logging), modify rsyslog.conf accordingly.

Change-Id: Ib4b48a468eff3f4f6fb9438821387225fc804f9c
Signed-off-by: Deepak Kodihalli <dkodihal@in.ibm.com>
diff --git a/recipes-extended/rsyslog/rsyslog_%.bbappend b/recipes-extended/rsyslog/rsyslog_%.bbappend
new file mode 100644
index 0000000..0a2fb33
--- /dev/null
+++ b/recipes-extended/rsyslog/rsyslog_%.bbappend
@@ -0,0 +1,16 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+
+SRC_URI += " \
+    file://rsyslog.conf \
+    file://server.conf \
+"
+
+PACKAGECONFIG ??= " \
+    rsyslogd rsyslogrt inet regexp uuid \
+    ${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)} \
+"
+
+do_install_append(){
+    install -m 0644 -D ${WORKDIR}/server.conf \
+        ${D}${sysconfdir}/rsyslog.d/server.conf
+}