remove manager classes

The value added by these classes is minimal and lowers the flexibility
available to clients using them when it comes to packaging.

Rename recipe virtuals - obmc-phosphor seems redundant.
Align package virtual names with best practices (virtual-package).

Change-Id: I34c3cb03f6b1d2aaa734ed02078b388667f70917
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/common/recipes-phosphor/events/obmc-phosphor-event.bb b/common/recipes-phosphor/events/obmc-phosphor-event.bb
index bd4d678..43825f4 100644
--- a/common/recipes-phosphor/events/obmc-phosphor-event.bb
+++ b/common/recipes-phosphor/events/obmc-phosphor-event.bb
@@ -5,10 +5,12 @@
 
 
 inherit obmc-phosphor-license
-inherit obmc-phosphor-event-mgmt
 inherit obmc-phosphor-dbus-service
 inherit obmc-phosphor-c-daemon
 
+PROVIDES += "virtual/obmc-event-mgmt"
+RPROVIDES_${PN} += "virtual-obmc-event-mgmt"
+
 TARGET_CXXFLAGS += " -std=c++11 -fpic"
 TARGET_CFLAGS += " -fpic"