remove manager classes

The value added by these classes is minimal and lowers the flexibility
available to clients using them when it comes to packaging.

Rename recipe virtuals - obmc-phosphor seems redundant.
Align package virtual names with best practices (virtual-package).

Change-Id: I34c3cb03f6b1d2aaa734ed02078b388667f70917
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/common/recipes-phosphor/fans/obmc-phosphor-fand.bb b/common/recipes-phosphor/fans/obmc-phosphor-fand.bb
index 8c937c6..89ab368 100644
--- a/common/recipes-phosphor/fans/obmc-phosphor-fand.bb
+++ b/common/recipes-phosphor/fans/obmc-phosphor-fand.bb
@@ -2,10 +2,12 @@
 DESCRIPTION = "Phosphor OpenBMC fan management reference implementation."
 PR = "r1"
 
-inherit obmc-phosphor-fan-mgmt
 inherit obmc-phosphor-sdbus-service
 inherit obmc-phosphor-c-daemon
 
+PROVIDES += "virtual/obmc-fan-mgmt"
+RPROVIDES_${PN} += "virtual-obmc-fan-mgmt"
+
 S = "${WORKDIR}"
 SRC_URI += "file://Makefile \
            file://obmc-phosphor-fand.c \