remove manager classes

The value added by these classes is minimal and lowers the flexibility
available to clients using them when it comes to packaging.

Rename recipe virtuals - obmc-phosphor seems redundant.
Align package virtual names with best practices (virtual-package).

Change-Id: I34c3cb03f6b1d2aaa734ed02078b388667f70917
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/common/recipes-phosphor/users/obmc-phosphor-user.bb b/common/recipes-phosphor/users/obmc-phosphor-user.bb
index 5f63b62..a307403 100644
--- a/common/recipes-phosphor/users/obmc-phosphor-user.bb
+++ b/common/recipes-phosphor/users/obmc-phosphor-user.bb
@@ -5,9 +5,11 @@
 
 inherit allarch
 inherit obmc-phosphor-license
-inherit obmc-phosphor-user-mgmt
 inherit obmc-phosphor-dbus-service
 
+PROVIDES += "virtual/obmc-user-mgmt"
+RPROVIDES_${PN} += "virtual-obmc-user-mgmt"
+
 RDEPENDS_${PN} += "python-dbus python-pygobject python-pexpect"
 
 SRC_URI += "git://github.com/openbmc/phosphor-networkd"