Add RDEPENDS to mtd-utils-ubifs in phosphor-software-manager

phosphor-software-manager is the recipe to manage software updates with
obmc-ubi-fs feature.

Missing the RDEPENDS will cause the built image to miss the ubi utils,
and code update will fail.

Resolves openbmc/openbmc#3177.

Tested: On a romulus build, verify there are no ubi utils without ubifs
        feature;
        verify there are ubi utils with ubifs feature.

Change-Id: Ib6de3ecee4d1b914e4dbc4df3c9c9e4baa1bb0be
Signed-off-by: Lei YU <mine260309@gmail.com>
diff --git a/common/recipes-phosphor/flash/phosphor-software-manager.bb b/common/recipes-phosphor/flash/phosphor-software-manager.bb
index 70db497..7587436 100644
--- a/common/recipes-phosphor/flash/phosphor-software-manager.bb
+++ b/common/recipes-phosphor/flash/phosphor-software-manager.bb
@@ -54,6 +54,9 @@
     virtual-obmc-image-manager \
     bash \
 "
+RDEPENDS_${PN}-updater_append_df-obmc-ubi-fs = " \
+    mtd-utils-ubifs \
+"
 
 RPROVIDES_${PN}-version += " \
     virtual-obmc-image-manager \