Add inventory manager class

Change-Id: Ib034680499f16efb842bc5074e269bb590f25fbd
diff --git a/common/recipes-phosphor/inventory/phosphor-inventory-manager-config-example-native.bb b/common/recipes-phosphor/inventory/phosphor-inventory-manager-config-example-native.bb
index 880d5ac..e59bc88 100644
--- a/common/recipes-phosphor/inventory/phosphor-inventory-manager-config-example-native.bb
+++ b/common/recipes-phosphor/inventory/phosphor-inventory-manager-config-example-native.bb
@@ -2,6 +2,7 @@
 PR = "r1"
 
 inherit native
+inherit phosphor-inventory-manager
 
 require phosphor-inventory-manager.inc
 
@@ -9,9 +10,9 @@
 
 do_install() {
         SRC=${S}/example
-        DEST=${D}${datadir}/phosphor-inventory-manager
+        DEST=${D}${base_datadir}
 
         for f in `find $SRC -type f -printf "%P\n"`; do
-                install -D ${SRC}/$f $DEST/$f
+                install -D ${SRC}/$f ${DEST}/$f
         done
 }