meta-phosphor: Create obmc-autotools to update AR and RANLIB

Many recipes are turning on -flto which causes issues
with the linker when dealing with libraries. It was suggested here
http://stackoverflow.com/questions/25878407/how-can-i-use-lto-with-static-libraries#comment67660913_25878408
to use the gcc wrappers to deal with this problem. Create flto-automake
class as this seems like something that could be globally applied
if needed.

Tested-by: phosphor-pid-control began to build, saw no new build
issues.

Change-Id: I589135327ae1510de6b17adbade37b3bbfc5909d
Signed-off-by: James Feist <james.feist@linux.intel.com>
diff --git a/recipes-phosphor/fans/phosphor-pid-control_git.bb b/recipes-phosphor/fans/phosphor-pid-control_git.bb
index ef0b543..8293c61 100644
--- a/recipes-phosphor/fans/phosphor-pid-control_git.bb
+++ b/recipes-phosphor/fans/phosphor-pid-control_git.bb
@@ -6,7 +6,7 @@
 LICENSE = "Apache-2.0"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
 
-inherit autotools pkgconfig
+inherit flto-automake pkgconfig
 inherit pythonnative
 
 inherit phosphor-pid-control