phosphor: Fix dbus-monitor install location

Address the common install-directly-into-sysroot bug.
Change from do_install_append to do_install as this is the
base recipe.

Change-Id: I11255d4713eeec9cdaca55ada21af80c7e192447
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/common/recipes-phosphor/dbus/phosphor-dbus-monitor-config-native.bb b/common/recipes-phosphor/dbus/phosphor-dbus-monitor-config-native.bb
index 178a941..228ae5a 100644
--- a/common/recipes-phosphor/dbus/phosphor-dbus-monitor-config-native.bb
+++ b/common/recipes-phosphor/dbus/phosphor-dbus-monitor-config-native.bb
@@ -15,6 +15,6 @@
 
 DEPENDS += "${PHOSPHOR_DBUS_MONITOR_CONFIGS}"
 
-do_install_append() {
-    mkdir -p ${config_dir}
+do_install() {
+    mkdir -p ${D}${config_dir}
 }