phosphor-user: Fix race-condition in build

phosphor-user was attempting to compile, even though it only needs
a python script out of a repository.  The compile depends on libsystemd
but systemd was not a DEPENDS.  Short-circuit by setting do_compile to
be empty.

Fixes openbmc/openbmc#511.

Change-Id: Idf4da676d8905a2900a7ecf40f120da431dd4300
Signed-off-by: Patrick Williams <patrick@stwcx.xyz>
diff --git a/common/recipes-phosphor/obmc-phosphor-user/obmc-phosphor-user.bb b/common/recipes-phosphor/obmc-phosphor-user/obmc-phosphor-user.bb
index 4877673..33a9ca0 100644
--- a/common/recipes-phosphor/obmc-phosphor-user/obmc-phosphor-user.bb
+++ b/common/recipes-phosphor/obmc-phosphor-user/obmc-phosphor-user.bb
@@ -16,6 +16,13 @@
 S = "${WORKDIR}/git"
 INSTALL_NAME = "userman.py"
 
+# Since base_do_compile finds a makefile (from networkd) it tries to
+# compile.  Short-circuit that because we just need to copy a python
+# file in this package.
+do_compile() {
+    :
+}
+
 do_install() {
 echo "***installing $INSTALL_NAME"
         install -d ${D}/${sbindir}