phosphor-settingsd: srcrev bump 3d805fe94a..6f62cc844b

And convert recipe to python3.

Patrick Williams (3):
      python2 to python3 conversion
      MAINTAINERS: update Deepak's email address
      delete deprecated python scripts

Change-Id: Ie00a27d4e8355307977ab1de12376b2879c0994f
Signed-off-by: Andrew Geissler <openbmcbump-github@yahoo.com>
diff --git a/recipes-phosphor/settings/phosphor-settings-manager_git.bb b/recipes-phosphor/settings/phosphor-settings-manager_git.bb
index e528111..85a63d2 100644
--- a/recipes-phosphor/settings/phosphor-settings-manager_git.bb
+++ b/recipes-phosphor/settings/phosphor-settings-manager_git.bb
@@ -6,15 +6,15 @@
 
 inherit autotools
 inherit obmc-phosphor-dbus-service
-inherit pythonnative
+inherit python3native
 inherit phosphor-settings-manager
 
 require phosphor-settings-manager.inc
 
 DBUS_SERVICE_${PN} = "xyz.openbmc_project.Settings.service"
 
-DEPENDS += "python-pyyaml-native"
-DEPENDS += "python-mako-native"
+DEPENDS += "${PYTHON_PN}-pyyaml-native"
+DEPENDS += "${PYTHON_PN}-mako-native"
 DEPENDS += "autoconf-archive-native"
 DEPENDS += "virtual/phosphor-settings-defaults"
 DEPENDS += "${@df_enabled(d, 'obmc-mrw', 'phosphor-settings-read-settings-mrw-native')}"