Only build FIT kernel images

U-Boot has support for FIT images enabled.  Yocto has been building both
cuImage and fitImage for a while now.  Dropping cuImage gets us closer
to mainline Yocto.  Using a FIT image clears the path for bundling the
initramfs into the kernel image.

Change-Id: I46f1e3d4196bab12b733c59efca40e9e50ca264d
Signed-off-by: Rick Altherr <raltherr@google.com>
diff --git a/classes/obmc-phosphor-image_types_uboot.bbclass b/classes/obmc-phosphor-image_types_uboot.bbclass
index 7e543de..193cf8c 100644
--- a/classes/obmc-phosphor-image_types_uboot.bbclass
+++ b/classes/obmc-phosphor-image_types_uboot.bbclass
@@ -6,7 +6,7 @@
 FLASH_IMAGE_NAME[vardepsexclude] = "DATETIME"
 FLASH_IMAGE_LINK ?= "flash-${MACHINE}"
 
-FLASH_KERNEL_IMAGETYPE ?= "cuImage"
+FLASH_KERNEL_IMAGETYPE ?= "fitImage"
 
 FLASH_UBOOT_OFFSET ?= "0"
 FLASH_KERNEL_OFFSET ?= "512"