gpio-monitor: Favor ALLOW_EMPTY

A number of recipes remove PN from the package list.  While this
seems to work it is unconventional and puts us into dusty corners
of oe-core/bitbake.

Adopt a more conventional approach with ALLOW_EMPTY_${PN} = "1".

Change-Id: Ic8effadedc073cc12bba46a1a635c72524602bf3
Tested: Built phosphor-gpio-monitor and validated package contents
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/common/recipes-phosphor/gpio/phosphor-gpio-monitor.bb b/common/recipes-phosphor/gpio/phosphor-gpio-monitor.bb
index 85317c0..fa63959 100644
--- a/common/recipes-phosphor/gpio/phosphor-gpio-monitor.bb
+++ b/common/recipes-phosphor/gpio/phosphor-gpio-monitor.bb
@@ -13,10 +13,8 @@
         ${PN}-presence \
 "
 
-PACKAGES += "${GPIO_PACKAGES}"
-PACKAGES_remove = "${PN}"
-RDEPENDS_${PN}-dev = "${GPIO_PACKAGES}"
-RDEPENDS_${PN}-staticdev = "${GPIO_PACKAGES}"
+PACKAGE_BEFORE_PN += "${GPIO_PACKAGES}"
+ALLOW_EMPTY_${PN} = "1"
 SYSTEMD_PACKAGES = "${GPIO_PACKAGES}"
 
 RPROVIDES_${PN}-monitor += "virtual/obmc-gpio-monitor"