phosphor-logging:  Add PEL PACKAGECONFIG

Create a PACKAGECONFIG option for phosphor-logging that allows one to
enable the OpenPower PEL extension, which, when enabled, will create
OpenPower Platform Event Log (PEL) format event logs for each OpenBMC
event log.

Change-Id: Ic21402072606b9c634301db6550402fb7f4f02c9
Signed-off-by: Matt Spinler <spinler@us.ibm.com>
diff --git a/recipes-phosphor/logging/phosphor-logging_git.bb b/recipes-phosphor/logging/phosphor-logging_git.bb
index 39bef14..a431b2c 100644
--- a/recipes-phosphor/logging/phosphor-logging_git.bb
+++ b/recipes-phosphor/logging/phosphor-logging_git.bb
@@ -92,6 +92,11 @@
         --disable-install_scripts, ,\
         "
 
+PACKAGECONFIG[openpower-pels] = " \
+        --enable-openpower-pel-extension, \
+        --disable-openpower-pel-extension, ,\
+        "
+
 # Enable install_scripts during native and native SDK build
 PACKAGECONFIG_add_class-native = "install_scripts"
 PACKAGECONFIG_add_class-nativesdk = "install_scripts"