u-boot: Move recipes to the Aspeed BSP layer

Move the u-boot recipes out of the Phosphor layer to the Aspeed layer.
When a SOC requires a specific u-boot tree, convention dictates the
BSP layer supporting the SOC includes recipes for that tree.

Tested: Built image and verified in witherspoon qemu
Change-Id: I4d5bade05566ae4cbcf5a2c637a1ed275c63ab36
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/common/recipes-bsp/u-boot/u-boot_%.bbappend b/common/recipes-bsp/u-boot/u-boot_%.bbappend
new file mode 100644
index 0000000..f9a1e83
--- /dev/null
+++ b/common/recipes-bsp/u-boot/u-boot_%.bbappend
@@ -0,0 +1,7 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
+
+include u-boot-aspeed.inc
+
+python do_configure () {
+    pass
+}