leds: Make phosphor-led-manager-config native

phosphor-led-manager-config is a meta-recipe that pulls in other native
recipes based on mrw enablement.

Switch from being a target recipe to a native recipe.  A native recipe
is more appropriate since a target recipe will cause bitbake to
create -dev packages and attempt to install those into an SDK.

Change-Id: I42af0796960cefe19d182afb2957e5c4853c6d28
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/common/recipes-phosphor/leds/phosphor-led-manager-config-native.bb b/common/recipes-phosphor/leds/phosphor-led-manager-config-native.bb
new file mode 100644
index 0000000..73812ea
--- /dev/null
+++ b/common/recipes-phosphor/leds/phosphor-led-manager-config-native.bb
@@ -0,0 +1,19 @@
+SUMMARY = "Phosphor LED Group Management meta data"
+PR = "r1"
+
+inherit obmc-phosphor-utils
+inherit obmc-phosphor-license
+inherit native
+
+# Default is the example set of data.
+PHOSPHOR_LED_MANAGER_CONFIG ??= "${BPN}-example-native"
+
+# Choose appropriate yaml file
+def get_depends(d):
+    if d.getVar('USE_MRW', 'yes'):
+        return "${BPN}-mrw-native"
+    else:
+        return "${PHOSPHOR_LED_MANAGER_CONFIG}"
+
+USE_MRW = "${@cf_enabled(d, 'obmc-mrw', 'yes')}"
+DEPENDS += "${@get_depends(d)}"