leds: Make phosphor-led-manager-config native

phosphor-led-manager-config is a meta-recipe that pulls in other native
recipes based on mrw enablement.

Switch from being a target recipe to a native recipe.  A native recipe
is more appropriate since a target recipe will cause bitbake to
create -dev packages and attempt to install those into an SDK.

Change-Id: I42af0796960cefe19d182afb2957e5c4853c6d28
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/common/recipes-phosphor/leds/phosphor-led-manager.bb b/common/recipes-phosphor/leds/phosphor-led-manager.bb
index 4757aa8..54996f9 100644
--- a/common/recipes-phosphor/leds/phosphor-led-manager.bb
+++ b/common/recipes-phosphor/leds/phosphor-led-manager.bb
@@ -9,7 +9,7 @@
 DEPENDS += "python-pyyaml-native"
 DEPENDS += "autoconf-archive-native"
 DEPENDS += "sdbusplus sdbusplus-native"
-DEPENDS += "${PN}-config"
+DEPENDS += "${PN}-config-native"
 RDEPENDS_${PN} += "libsystemd"
 
 S = "${WORKDIR}/git"