u-boot: add u-boot-common.inc

Factor out variables needed by both fw-utils and the base recipe into a
common include.

u-boot.inc tried to do this but a number of ubi bootenv patches that
aren't needed by fw-utils were pulled in there.

Change-Id: Ia7006e620892030d05cb62cfb251143d0af54b42
Tested: Built witherspoon and palmetto images, verified u-boot, fw-utils
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/common/recipes-bsp/u-boot/u-boot-fw-utils_2016.07.bb b/common/recipes-bsp/u-boot/u-boot-fw-utils_2016.07.bb
index 251e044..6e2aeac 100644
--- a/common/recipes-bsp/u-boot/u-boot-fw-utils_2016.07.bb
+++ b/common/recipes-bsp/u-boot/u-boot-fw-utils_2016.07.bb
@@ -1,11 +1,7 @@
 SUMMARY = "U-Boot bootloader fw_printenv/setenv utilities"
-LICENSE = "GPLv2+"
-SECTION = "bootloader"
 DEPENDS = "mtd-utils"
 
-require u-boot.inc
-
-S = "${WORKDIR}/git"
+require u-boot-common.inc
 
 INSANE_SKIP_${PN} = "already-stripped"
 EXTRA_OEMAKE_class-target = 'CROSS_COMPILE=${TARGET_PREFIX} CC="${CC} ${CFLAGS} ${LDFLAGS}" V=1'