simplify setting of KERNEL_DANGLING_FEATURES_WARN_ONLY
Setting this within python is not required
Change-Id: Ic3f6ea6470f2cb87ab3fd5e2c2f9aa50f03d2014
Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
diff --git a/aspeed-layer/recipes-kernel/linux/linux-aspeed_%.bbappend b/aspeed-layer/recipes-kernel/linux/linux-aspeed_%.bbappend
index 6acd6a6..8dd381e 100644
--- a/aspeed-layer/recipes-kernel/linux/linux-aspeed_%.bbappend
+++ b/aspeed-layer/recipes-kernel/linux/linux-aspeed_%.bbappend
@@ -10,9 +10,6 @@
KERNEL_FEATURES_append = " phosphor-vlan"
KERNEL_FEATURES_remove_qemuall = " phosphor-vlan"
-python () {
- # OpenBMC loads in kernel features via other mechanisms so this check
- # in the kernel-yocto.bbclass is not required
- d.setVar("KERNEL_DANGLING_FEATURES_WARN_ONLY","1")
-}
-
+# OpenBMC loads in kernel features via other mechanisms so this check
+# in the kernel-yocto.bbclass is not required
+KERNEL_DANGLING_FEATURES_WARN_ONLY="1"