simplify setting of KERNEL_DANGLING_FEATURES_WARN_ONLY

Setting this within python is not required

Change-Id: Ic3f6ea6470f2cb87ab3fd5e2c2f9aa50f03d2014
Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
diff --git a/nuvoton-layer/recipes-kernel/linux/linux-nuvoton_%.bbappend b/nuvoton-layer/recipes-kernel/linux/linux-nuvoton_%.bbappend
index 88b3860..3d0bbb7 100644
--- a/nuvoton-layer/recipes-kernel/linux/linux-nuvoton_%.bbappend
+++ b/nuvoton-layer/recipes-kernel/linux/linux-nuvoton_%.bbappend
@@ -3,10 +3,6 @@
 SRC_URI += "file://phosphor-gpio-keys.scc"
 SRC_URI += "file://phosphor-gpio-keys.cfg"
 
-
-python () {
-    # OpenBMC loads in kernel features via other mechanisms so this check
-    # in the kernel-yocto.bbclass is not required
-    d.setVar("KERNEL_DANGLING_FEATURES_WARN_ONLY","1")
-}
-
+# OpenBMC loads in kernel features via other mechanisms so this check
+# in the kernel-yocto.bbclass is not required
+KERNEL_DANGLING_FEATURES_WARN_ONLY="1"