Dropbear: upgrade options for latest upgrade

Yocto 2.6 upgrades our version of dropbear.  Prepare for the upgrade.

1. Implement the new options system so we can upgrade without losing our
options.

Options available are described here:
https://github.com/mkj/dropbear/blob/master/default_options.h

Note, DROPBEAR_TWOFISH256, and DROPBEAR_TWOFISH128 options are dropped,
as they are not enabled in the default config.

2. Drop the -c option patch, as this has bene included in dropbear for some
time, and now conflicts with itself in merging.
https://github.com/mkj/dropbear/commit/ac9a4c839f6cbde3ca8226d79eca36a497620594

3. Drop the default host keys patch, as it is now in master, although it
does'nt conflict
https://github.com/mkj/dropbear/commit/4c95d595c00818f61905a9d607e3fd675ba85458

Change-Id: Ie691d2b56ddd8e8ddb08384e0f1c9d70e4798e30
Signed-off-by: Ed Tanous <ed.tanous@intel.com>
diff --git a/recipes-core/dropbear/dropbear_%.bbappend b/recipes-core/dropbear/dropbear_%.bbappend
index 8071497..cab454a 100644
--- a/recipes-core/dropbear/dropbear_%.bbappend
+++ b/recipes-core/dropbear/dropbear_%.bbappend
@@ -3,5 +3,4 @@
 # to yocto 2.5 or later which will pull in the latest dropbear code.
 FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
 SRC_URI += "file://dropbearkey.service \
-	    file://0001-dropbear-Add-c-command-option-to-force-a-specific-co.patch \
-	    file://0001-Only-load-dropbear-default-host-keys-if-a-key-is-not.patch"
+            file://localoptions.h"