meta-phosphor: ipmi: flash: add layout options

The library will support by default a few flash options: the host bios,
a static layout bmc image, and later a ubi-tarball approach.

Other options later will include tying into bmc-code-mgmt allowing
static tarballs, etc.

Signed-off-by: Patrick Venture <venture@google.com>
Change-Id: I05e758039d9356a7ca89131867bcd5ee0aad680a
diff --git a/recipes-phosphor/ipmi/phosphor-ipmi-flash_git.bb b/recipes-phosphor/ipmi/phosphor-ipmi-flash_git.bb
index 3bf7ca7..ed7afff 100644
--- a/recipes-phosphor/ipmi/phosphor-ipmi-flash_git.bb
+++ b/recipes-phosphor/ipmi/phosphor-ipmi-flash_git.bb
@@ -22,6 +22,10 @@
 PACKAGECONFIG[cleanup-delete] = "--enable-cleanup-delete, --disable-cleanup-delete"
 # If using static-layout, reboot-update is a good option to handle updating.
 PACKAGECONFIG[reboot-update] = "--enable-reboot-update, --disable-reboot-update"
+
+# Default options for supporting various flash types:
+PACKAGECONFIG[static-bmc] = "--enable-static-layout, --disable-static-layout"
+PACKAGECONFIG[ubitar-bmc] = "--enable-tarball-ubi, --disable-tarball-ubi"
 PACKAGECONFIG[host-bios] = "--enable-host-bios, --disable-host-bios"
 
 # Hardware options to enable transmitting the data from the host.