sdbusplus: remove unused python2 recipe

All recipes consuming sdbus++ have now migrated to the python3
version.  Remove the python2 version.

Signed-off-by: Patrick Williams <patrick@stwcx.xyz>
Change-Id: I7c3c36e38e5b16941e34f3b03b6cf205f43d2a42
diff --git a/recipes-extended/sdbusplus/python3-sdbus++_git.bb b/recipes-extended/sdbusplus/python3-sdbus++_git.bb
index 829d496..bf815ce 100644
--- a/recipes-extended/sdbusplus/python3-sdbus++_git.bb
+++ b/recipes-extended/sdbusplus/python3-sdbus++_git.bb
@@ -1,2 +1,31 @@
+SUMMARY = "sdbus++ dbus API / binding generator"
+DESCRIPTION = "Generates bindings against sdbusplus for dbus APIs"
+
+inherit autotools pkgconfig
 inherit obmc-phosphor-python3-autotools
-include sdbus++.inc
+
+include sdbusplus-rev.inc
+
+# Provide these aliases temporarily until everyone can move over to the
+# new package name.
+PROVIDES_class-native += "sdbusplus-native"
+PROVIDES_class-nativesdk += "sdbusplus-nativesdk"
+
+DEPENDS += " \
+    autoconf-archive-native \
+    ${PYTHON_PN}-inflection-native \
+    ${PYTHON_PN}-mako-native \
+    ${PYTHON_PN}-pyyaml-native \
+    "
+
+RDEPENDS_${PN} += " \
+    ${PYTHON_PN}-inflection \
+    ${PYTHON_PN}-mako \
+    ${PYTHON_PN}-pyyaml \
+    "
+
+PACKAGECONFIG ??= "transaction"
+PACKAGECONFIG[libsdbusplus] = "--enable-libsdbusplus,--disable-libsdbusplus,systemd,libsystemd"
+PACKAGECONFIG[transaction] = "--enable-transaction,--disable-transaction"
+
+BBCLASSEXTEND += "native nativesdk"