obmc-console: Rename recipe

OE norms dictate recipes that track HEAD be named:

foo_git.bb

and set PV explicitly to "x.y.z+git${SRCPV}"

Change-Id: Iaeffab1e3bb1df6720ae4e236c3515fb1ec30cc8
Tested: Built the obmc-console recipe
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/common/recipes-phosphor/console/obmc-console_git.bb b/common/recipes-phosphor/console/obmc-console_git.bb
new file mode 100644
index 0000000..c7fe640
--- /dev/null
+++ b/common/recipes-phosphor/console/obmc-console_git.bb
@@ -0,0 +1,37 @@
+SUMMARY = "OpenBMC console daemon"
+DESCRIPTION = "Daemon to handle UART console connections"
+HOMEPAGE = "http://github.com/openbmc/obmc-console"
+PR = "r1"
+
+inherit obmc-phosphor-license
+inherit obmc-phosphor-systemd
+inherit autotools
+inherit obmc-phosphor-discovery-service
+
+TARGET_CFLAGS   += "-fpic -O2"
+
+DEPENDS += "autoconf-archive-native"
+
+SRC_URI += "git://github.com/openbmc/obmc-console"
+SRC_URI += "file://${PN}.conf"
+
+SRCREV = "c7fbcd480fb03840a4c44e546af878e84400b6fe"
+PV = "1.0+git${SRCPV}"
+
+REGISTERED_SERVICES_${PN} += "obmc_console:tcp:2200"
+OBMC_CONSOLE_HOST_TTY ?= "ttyVUART0"
+SYSTEMD_SUBSTITUTIONS += "OBMC_CONSOLE_HOST_TTY:${OBMC_CONSOLE_HOST_TTY}:${PN}-ssh@.service"
+SYSTEMD_SUBSTITUTIONS += "OBMC_CONSOLE_HOST_TTY:${OBMC_CONSOLE_HOST_TTY}:${PN}-ssh.socket"
+
+SYSTEMD_SERVICE_${PN} = " \
+        ${PN}@.service \
+        ${PN}@${OBMC_CONSOLE_HOST_TTY}.service \
+        ${PN}-ssh.socket \
+        ${PN}-ssh@.service \
+        "
+do_install_append() {
+        install -m 0755 -d ${D}${sysconfdir}
+        install -m 0644 ${WORKDIR}/${PN}.conf ${D}${sysconfdir}/${PN}.conf
+}
+
+S = "${WORKDIR}/git"