Bump versions for skeleton, rest, inarp, event

Bump recipe versions and add python dependencies.
The rest-dbus recipe was adding pythong packages needed
by other processes, so when rest-dbus was removed from the
Barreleye image, these processes (skeleton and obmc-rest)
would fail, so adding the python dependencies to those recipes.

Signed-off-by: Adriana Kobylak <anoo@us.ibm.com>
diff --git a/common/recipes-phosphor/skeleton/skeleton.bb b/common/recipes-phosphor/skeleton/skeleton.bb
index 4dc9dff..4402227 100644
--- a/common/recipes-phosphor/skeleton/skeleton.bb
+++ b/common/recipes-phosphor/skeleton/skeleton.bb
@@ -17,7 +17,7 @@
 VIRTUAL-RUNTIME_skeleton_workbook ?= ""
 
 DEPENDS += "glib-2.0 systemd python"
-RDEPENDS_${PN} += "python-subprocess python-compression libsystemd ${VIRTUAL-RUNTIME_skeleton_workbook}"
+RDEPENDS_${PN} += "python-json python-subprocess python-compression libsystemd ${VIRTUAL-RUNTIME_skeleton_workbook}"
 SRC_URI += "git://github.com/openbmc/skeleton"
 
 FILES_${PN} += "${PYTHON_SITEPACKAGES_DIR}/*"
@@ -26,7 +26,7 @@
 PACKAGECONFIG ??= "${@bb.utils.contains('MACHINE_FEATURES', 'openpower-pflash', 'openpower-pflash', '', d)}"
 PACKAGECONFIG[openpower-pflash] = ",,,pflash"
 
-SRCREV = "40187443840d0e419c13391b2091fda29d63dea4"
+SRCREV = "cbe32133dadf0945357e2bec67aa7a86ae9f0295"
 
 S = "${WORKDIR}"