phosphor-software-manager: Add ACTIVE_BMC_MAX_ALLOWED config

For static flash layout, configure ACTIVE_BMC_MAX_ALLOWED to 1, because
it has only one active BMC image;
For ubi-fs, configure ACTIVE_BMC_MAX_ALLOWED to 2, because ubi-fs
assumes there are two BMC images by default.

Resolves openbmc/phosphor-bmc-code-mgmt#2

Tested: Verify that ACTIVE_BMC_MAX_ALLOWED is set to 1 for Romulus
        build, and set to 2 for Witherspoon build.

Change-Id: I89b26f2dbd4640c9813d975dc603ffc875af8837
Signed-off-by: Lei YU <mine260309@gmail.com>
diff --git a/common/recipes-phosphor/flash/phosphor-software-manager.bb b/common/recipes-phosphor/flash/phosphor-software-manager.bb
index eb2468d..0b6723c 100644
--- a/common/recipes-phosphor/flash/phosphor-software-manager.bb
+++ b/common/recipes-phosphor/flash/phosphor-software-manager.bb
@@ -57,6 +57,7 @@
     virtual-obmc-image-manager \
 "
 EXTRA_OECONF += " \
+    ACTIVE_BMC_MAX_ALLOWED=1 \
     MEDIA_DIR=/run/media \
 "