Add boost-url recipe

This adds boost-url, a header only url parsing library
based on and created by one of the authors of boost
beast. This will be used to replace QueryString in
bmcweb, which is a part that was originally from crow
that has been flagged for issues many times.

Usage:
https://gerrit.openbmc-project.xyz/c/openbmc/bmcweb/+/34973

Tested:
Using bmcweb, url params worked

Change-Id: I89e16a8908056248bc8a464e7f1024a300e7f656
Signed-off-by: James Feist <james.feist@linux.intel.com>
diff --git a/recipes-phosphor/interfaces/bmcweb_git.bb b/recipes-phosphor/interfaces/bmcweb_git.bb
index 4c49410..0492bdd 100644
--- a/recipes-phosphor/interfaces/bmcweb_git.bb
+++ b/recipes-phosphor/interfaces/bmcweb_git.bb
@@ -17,7 +17,15 @@
 
 S = "${WORKDIR}/git"
 
-DEPENDS = "openssl zlib boost libpam sdbusplus gtest nlohmann-json libtinyxml2 "
+DEPENDS = "openssl \
+           zlib \
+           boost \
+           boost-url \
+           libpam \
+           sdbusplus \
+           gtest \
+           nlohmann-json \
+           libtinyxml2 "
 
 RDEPENDS_${PN} += "jsnbd"