Add boost-url recipe

This adds boost-url, a header only url parsing library
based on and created by one of the authors of boost
beast. This will be used to replace QueryString in
bmcweb, which is a part that was originally from crow
that has been flagged for issues many times.

Usage:
https://gerrit.openbmc-project.xyz/c/openbmc/bmcweb/+/34973

Tested:
Using bmcweb, url params worked

Change-Id: I89e16a8908056248bc8a464e7f1024a300e7f656
Signed-off-by: James Feist <james.feist@linux.intel.com>
diff --git a/recipes-support/boost-url/boost-url_git.bb b/recipes-support/boost-url/boost-url_git.bb
new file mode 100644
index 0000000..6d4635b
--- /dev/null
+++ b/recipes-support/boost-url/boost-url_git.bb
@@ -0,0 +1,17 @@
+DESCRIPTION = "Boost.URL is a library for manipulating Uniform Resource Identifiers (URI) and Locators (URL)"
+HOMEPAGE = "https://github.com/CPPAlliance/url"
+SECTION = "libs"
+LICENSE = "BSL-1.0"
+LIC_FILES_CHKSUM = "file://LICENSE_1_0.txt;md5=e4224ccaecb14d942c71d31bef20d78c"
+
+SRC_URI = "git://github.com/CPPAlliance/url.git"
+
+SRCREV = "a56ae0df6d3078319755fbaa67822b4fa7fd352b"
+
+S = "${WORKDIR}/git"
+
+inherit cmake
+
+DEPENDS = "boost"
+
+BBCLASSEXTEND = "native nativesdk"