meta-openpower: Convert MACHINE_FEATURE openpower-pflash to openpower-ubi-fs

Since pflash is no longer used when openpower-ubi-fs is enabled and
the only use of the openpower-pflash feature was to enable a pflash
dependency in obmc-op-flasher, remove obmc-op-flasher when
openpower-ubi-fs is enabled (thus removing pflash from the machine).

Change-Id: Ia11d2b11ac201a139e1c4d014d539d346e0c2479
Signed-off-by: Patrick Williams <patrick@stwcx.xyz>
diff --git a/common/recipes-phosphor/flash/obmc-op-flasher.bb b/common/recipes-phosphor/flash/obmc-op-flasher.bb
index 9908500..d3d1290 100644
--- a/common/recipes-phosphor/flash/obmc-op-flasher.bb
+++ b/common/recipes-phosphor/flash/obmc-op-flasher.bb
@@ -4,8 +4,7 @@
 
 inherit skeleton-gdbus
 
-# DEPEND,RDEPEND on pflash if the openpower-pflash machine feature is set.
-PACKAGECONFIG ??= "${@bb.utils.contains('MACHINE_FEATURES', 'openpower-pflash', 'openpower-pflash', '', d)}"
-PACKAGECONFIG[openpower-pflash] = ",,pflash,pflash"
+DEPENDS += "pflash"
+RDEPENDS_${PN} += "pflash"
 
 SKELETON_DIR = "op-flasher"