ipmi-net: Restore the persisted iptables filter

If the persisted iptables filter exist restore the filter.

Tested: The iptables filter is restored when the phosphor-ipmi-net

Change-Id: I8486f2928374ae6ea1b164426c405462ba0eabc8
Signed-off-by: Tom Joseph <tomjoseph@in.ibm.com>
diff --git a/recipes-phosphor/ipmi/phosphor-ipmi-net_git.bb b/recipes-phosphor/ipmi/phosphor-ipmi-net_git.bb
index c5984f1..27837fd 100644
--- a/recipes-phosphor/ipmi/phosphor-ipmi-net_git.bb
+++ b/recipes-phosphor/ipmi/phosphor-ipmi-net_git.bb
@@ -23,10 +23,16 @@
 GROUPADD_PARAM_${PN} = "ipmi"
 
 SRC_URI += "git://github.com/openbmc/phosphor-net-ipmid"
+SRC_URI += "file://ipmi-net-firewall.sh"
 SRCREV = "5e452093830644245b83a817b8dad2fdb36ea550"
 
 S = "${WORKDIR}/git"
 
+do_install_append() {
+        install -m 0755 ${WORKDIR}/ipmi-net-firewall.sh \
+        ${D}${sbindir}/ipmi-net-firewall.sh
+}
+
 SYSTEMD_SERVICE_${PN} = " \
         ${PN}.service \
         ${PN}.socket \