fans: Remove presence-example recipe

Replace the fan-presence example recipe with a re-usable
"hardcoded" config recipe.

Change-Id: I47fba19eb9243d123a44e448ebf4322593074e1c
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/common/recipes-phosphor/fans/phosphor-fan-presence-config-native.bb b/common/recipes-phosphor/fans/phosphor-fan-presence-config-native.bb
new file mode 100644
index 0000000..0eb3873
--- /dev/null
+++ b/common/recipes-phosphor/fans/phosphor-fan-presence-config-native.bb
@@ -0,0 +1,22 @@
+# Provides the config file for the phosphor-fan-presence application.
+# The default config file is empty.  To provide a real one,
+# append this recipe in a layer, add:
+# FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+# and provide a config file.
+
+SUMMARY = "Config file for phosphor-fan-presence"
+PR = "r1"
+
+inherit native
+inherit phosphor-fan
+inherit obmc-phosphor-license
+
+PROVIDES += "virtual/phosphor-fan-presence-config"
+
+SRC_URI += "file://config.yaml"
+
+S = "${WORKDIR}"
+
+do_install() {
+        install -D config.yaml ${D}${presence_datadir}/config.yaml
+}