meta-phosphor: phosphor-pid-control: transition away from YAML

phosphor-pid-control no longer relies on a native recipes to provide a
yaml configuration that is compiled into the binary.

To enable this, srcrev bump f72ad44140..dca2d484ee

James Feist (1):
      DBusConfiguration: Fix scaling

Patrick Venture (3):
      main: add json configuration path
      main: if json configuration, override yaml built
      build: drop support for YAML configurations

Change-Id: I615efcf187dfee0ab5040b064a0aa46c5fa66315
Signed-off-by: Andrew Geissler <openbmcbump-github@yahoo.com>
Signed-off-by: Patrick Venture <venture@google.com>
diff --git a/classes/phosphor-pid-control.bbclass b/classes/phosphor-pid-control.bbclass
index 573420b..482b218 100644
--- a/classes/phosphor-pid-control.bbclass
+++ b/classes/phosphor-pid-control.bbclass
@@ -1,2 +1,5 @@
-sensor_datadir="${datadir}/swampd/sensor"
+config_datadir="${datadir}/swampd/"
+# config_path is the location swampd expects to find a json configuration.
+# the file is expected to be named config.json
+config_path="${config_datadir}/config.json"