meta-phosphor: phosphor-pid-control: transition away from YAML

phosphor-pid-control no longer relies on a native recipes to provide a
yaml configuration that is compiled into the binary.

To enable this, srcrev bump f72ad44140..dca2d484ee

James Feist (1):
      DBusConfiguration: Fix scaling

Patrick Venture (3):
      main: add json configuration path
      main: if json configuration, override yaml built
      build: drop support for YAML configurations

Change-Id: I615efcf187dfee0ab5040b064a0aa46c5fa66315
Signed-off-by: Andrew Geissler <openbmcbump-github@yahoo.com>
Signed-off-by: Patrick Venture <venture@google.com>
diff --git a/recipes-phosphor/fans/phosphor-pid-control_git.bb b/recipes-phosphor/fans/phosphor-pid-control_git.bb
index d819c29..2cdb8b2 100644
--- a/recipes-phosphor/fans/phosphor-pid-control_git.bb
+++ b/recipes-phosphor/fans/phosphor-pid-control_git.bb
@@ -14,7 +14,7 @@
 
 S = "${WORKDIR}/git"
 SRC_URI = "git://github.com/openbmc/phosphor-pid-control"
-SRCREV = "f72ad441408ffb671c412c9f79795236c0ea5e54"
+SRCREV = "dca2d484ee91ee40fc94509d831ef2c5fa792ca0"
 
 # Each platform will need a service file that starts
 # at an appropriate time per system.  For instance, if
@@ -29,8 +29,6 @@
 DEPENDS += "libevdev"
 DEPENDS += "nlohmann-json"
 
-# We depend on someone providing their system's configuration.
-DEPENDS += "virtual/phosphor-fans-sensor-inventory"
 # We depend on this to be built first so we can build our providers.
 DEPENDS += "phosphor-ipmi-host"
 
@@ -44,8 +42,4 @@
 FILES_${PN}_append = " ${libdir}/net-ipmid/lib*${SOLIBS}"
 FILES_${PN}-dev_append = " ${libdir}/ipmid-providers/lib*${SOLIBSDEV} ${libdir}/ipmid-providers/*.la"
 
-EXTRA_OECONF = "SENSOR_YAML_GEN=${STAGING_DIR_NATIVE}${sensor_datadir}/sensor-list.yaml \
-                PID_YAML_GEN=${STAGING_DIR_NATIVE}${sensor_datadir}/pid-list.yaml \
-                ZONE_YAML_GEN=${STAGING_DIR_NATIVE}${sensor_datadir}/zone-info.yaml"
-
 HOSTIPMI_PROVIDER_LIBRARY += "libmanualcmds.so"