Add required package "pkgconfig"

This package is required for the following receipes
in yocto-2.3.
Otherwise we get the error:
"fatal error: gio/gio.h: No such file or directory"

Change-Id: I020c8f31d707da716956b7856ba14076294bd7c7
Signed-off-by: Saqib Khan <khansa@us.ibm.com>
diff --git a/common/recipes-phosphor/system/obmc-control-bmc.bb b/common/recipes-phosphor/system/obmc-control-bmc.bb
index 99f5618..eb5b4a8 100644
--- a/common/recipes-phosphor/system/obmc-control-bmc.bb
+++ b/common/recipes-phosphor/system/obmc-control-bmc.bb
@@ -5,6 +5,7 @@
 
 inherit skeleton-gdbus
 inherit obmc-phosphor-dbus-service
+inherit pkgconfig
 
 SKELETON_DIR = "bmcctl"