Provide the phosphor-fan-presence config YAML

On MRW based systems, this YAML will be generated from the
MRW XML, otherwise the example YAML provided by the
phosphor-fan-presence repository will be used in the build.

Change-Id: I1bf914a7e26067f62f2b2bf8b7ba1ba43591c5dc
Signed-off-by: Matt Spinler <spinler@us.ibm.com>
diff --git a/common/recipes-phosphor/fans/phosphor-fan-presence.bb b/common/recipes-phosphor/fans/phosphor-fan-presence.bb
index ec17267..2d5b5b8 100644
--- a/common/recipes-phosphor/fans/phosphor-fan-presence.bb
+++ b/common/recipes-phosphor/fans/phosphor-fan-presence.bb
@@ -2,18 +2,20 @@
 DESCRIPTION = "Phosphor fan presence provides a set of fan presence \
 daemons to monitor fan presence changes by different methods of \
 presence detection."
-HOMEPAGE = "https://github.com/openbmc/phosphor-fan-presence"
 PR = "r1"
-LICENSE = "Apache-2.0"
-LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
+
+require ${PN}.inc
 
 inherit autotools pkgconfig pythonnative
 inherit obmc-phosphor-systemd
+inherit phosphor-fan-presence
 
 DEPENDS += "autoconf-archive-native"
 DEPENDS += "python-pyyaml-native"
+DEPENDS += "python-mako-native"
 DEPENDS += "sdbusplus"
 DEPENDS += "phosphor-logging"
+DEPENDS += "virtual/phosphor-fan-presence-config"
 RDEPENDS_${PN} += "sdbusplus"
 
 FAN_PRESENCE_PACKAGES = " \
@@ -34,7 +36,7 @@
 SYSTEMD_SERVICE_${PN}-tach += "${TMPL}"
 SYSTEMD_LINK_${PN} += "${@compose_list(d, 'FMT', 'OBMC_CHASSIS_INSTANCES')}"
 
-SRC_URI += "git://github.com/openbmc/phosphor-fan-presence"
-SRCREV = "2b44a6c0b282cf50c563a175535c4c32f55a81dc"
-
 S = "${WORKDIR}/git"
+
+EXTRA_OECONF = \
+    "FAN_DETECT_YAML_FILE=${STAGING_DIR_NATIVE}${presence_datadir}/config.yaml"