Templatize host-failure-reboots service

This service touches a host0 setting, so it
needs to be a template and touch host%i.

Change-Id: I9cf84ec40f5fe3aa1ad2c420aaa26d522eece6e1
Signed-off-by: Matt Spinler <spinler@us.ibm.com>
diff --git a/common/recipes-phosphor/chassis/obmc-host-failure-reboots.bb b/common/recipes-phosphor/chassis/obmc-host-failure-reboots.bb
index e0f9b84..645f40c 100644
--- a/common/recipes-phosphor/chassis/obmc-host-failure-reboots.bb
+++ b/common/recipes-phosphor/chassis/obmc-host-failure-reboots.bb
@@ -6,4 +6,9 @@
 inherit obmc-phosphor-systemd
 inherit obmc-phosphor-license
 
-SYSTEMD_SERVICE_${PN} += "host-failure-reboots.service"
+TMPL = "host-failure-reboots@.service"
+INSTFMT = "host-failure-reboots@{0}.service"
+LINK_FMT = "${TMPL}:${INSTFMT}"
+
+SYSTEMD_SERVICE_${PN} += "${TMPL}"
+SYSTEMD_LINK_${PN} += "${@compose_list(d, 'LINK_FMT', 'OBMC_HOST_INSTANCES')}"