Update kernel version

The kernel contains many changes, including

  - rewritten i2c driver
  - interrupt facilities for the iBT host driver
  - drop dts patches, we now use the in-tree device tree
  - rebased on Linux 4.3
diff --git a/common/recipes-kernel/linux/linux-obmc_4.3.bb b/common/recipes-kernel/linux/linux-obmc_4.3.bb
new file mode 100644
index 0000000..2b2ff39
--- /dev/null
+++ b/common/recipes-kernel/linux/linux-obmc_4.3.bb
@@ -0,0 +1,30 @@
+DESCRIPTION = "Linux kernel for OpenBMC"
+SECTION = "kernel"
+LICENSE = "GPLv2"
+
+KBRANCH ?= "dev-4.3"
+KCONFIG_MODE="--alldefconfig"
+
+SRC_URI = "git://github.com/openbmc/linux;protocol=git;branch=${KBRANCH}"
+
+LINUX_VERSION ?= "4.3"
+LINUX_VERSION_EXTENSION ?= "-${SRCREV}"
+
+SRCREV="openbmc-20151123-1"
+
+PV = "${LINUX_VERSION}+git${SRCPV}"
+
+COMPATIBLE_MACHINE_${MACHINE} = "openbmc"
+
+inherit kernel
+require recipes-kernel/linux/linux-yocto.inc
+
+do_patch_append() {
+        for DTB in "${KERNEL_DEVICETREE}"; do
+		DT=`basename ${DTB} .dtb`
+                if [ -r "${WORKDIR}/${DT}.dts" ]; then
+                        cp ${WORKDIR}/${DT}.dts \
+                                ${STAGING_KERNEL_DIR}/arch/${ARCH}/boot/dts
+		fi
+	done
+}