Add in new host reboot target

The state management code on the BMC is designed to
utilize systemd targets as much as possible. The host
reboot was always the odd duck that had some special
code written to support it. This special code would
basically issue a power off, look for it to complete
and then issue a power on. This is very error prone
code and has resulted in a few issues.

Moving to a single systemd target (the new reboot target)
defined here will allow the host reboots to occur
solely through a single systemd target now.

openbmc/openbmc#2032 is one of those bugs being
addressed with this change.

Change-Id: If33454aa4f15580e45f888a9b1602dec24a46fca
Signed-off-by: Andrew Geissler <andrewg@us.ibm.com>
diff --git a/common/recipes-core/systemd/obmc-targets.bb b/common/recipes-core/systemd/obmc-targets.bb
index 07c2d67..c3bcd73 100644
--- a/common/recipes-core/systemd/obmc-targets.bb
+++ b/common/recipes-core/systemd/obmc-targets.bb
@@ -40,7 +40,8 @@
 #            quiesce target but the only delta is that this target contains
 #            multiple services and one of them is the quiesce target.
 # - timeout: Target to run when host watchdog times out
-HOST_ACTION_TARGETS = "start stop quiesce reset shutdown crash timeout"
+# - reboot:  Reboot the host
+HOST_ACTION_TARGETS = "start stop quiesce reset shutdown crash timeout reboot"
 
 CHASSIS_SYNCH_FMT = "obmc-power-{0}@.target"
 CHASSIS_ACTION_FMT = "obmc-chassis-{0}@.target"