Update nslcd conf to avoid ldap lookups for local groups

Currently when there is no ldap configuration,
nslcd daemon starts with default config which has
URI ldap://127.0.0.1, then we notice unnecessary nslcd
LDAP lookups for all local groups.

this commit updates config with "nss_initgroups_ignoreusers ALLLOCAL"
this option filters out all LDAP lookups for all local groups.

Tested by:
1.reboot system and check traces
2.restarting nslcd service and check traces

Signed-off-by: Ravi Teja <raviteja28031990@gmail.com>
Change-Id: I90949448994638a253995e3845898c7197ce9eca
diff --git a/recipes-support/nss-pam-ldapd_fix/nss-pam-ldapd_%.bbappend b/recipes-support/nss-pam-ldapd_fix/nss-pam-ldapd_%.bbappend
index d1b092d..11e8c4a 100644
--- a/recipes-support/nss-pam-ldapd_fix/nss-pam-ldapd_%.bbappend
+++ b/recipes-support/nss-pam-ldapd_fix/nss-pam-ldapd_%.bbappend
@@ -1,3 +1,5 @@
 do_install_append() {
+        sed -i -e '$anss_initgroups_ignoreusers ALLLOCAL' ${D}${sysconfdir}/nslcd.conf
+
         install -m 0644 ${D}${sysconfdir}/nslcd.conf ${D}${sysconfdir}/nslcd.conf.default
 }