meta-phosphor: Add systemd service file for pid control

Added systemd sevice xyz.openbmc_project.phosphor-pid-control.service
file for phosphor-pid-control

srcrev bump 11d243dfdd..e7f4a5d5c9
Patrick Venture (1):
      README: configure: fixup markdown

Vijay Khemka (1):
      Adding service file

Change-Id: I0c813e57cf1fa6b579c6410ec8d01b46213eaf63
Signed-off-by: Vijay Khemka <vijaykhemka@fb.com>
diff --git a/recipes-phosphor/fans/phosphor-pid-control_git.bb b/recipes-phosphor/fans/phosphor-pid-control_git.bb
index a6bdc54..0f95797 100644
--- a/recipes-phosphor/fans/phosphor-pid-control_git.bb
+++ b/recipes-phosphor/fans/phosphor-pid-control_git.bb
@@ -10,10 +10,11 @@
 
 inherit phosphor-pid-control
 inherit obmc-phosphor-ipmiprovider-symlink
+inherit systemd
 
 S = "${WORKDIR}/git"
 SRC_URI = "git://github.com/openbmc/phosphor-pid-control"
-SRCREV = "11d243dfdd647afe471d650c4408627361f2acf3"
+SRCREV = "e7f4a5d5c93b8ee7e91351c6f7c3e66f03cb40f5"
 
 # Each platform will need a service file that starts
 # at an appropriate time per system.  For instance, if
@@ -32,6 +33,14 @@
 # We depend on this to be built first so we can build our providers.
 DEPENDS += "phosphor-ipmi-host"
 
+SERVICE_FILE = "phosphor-pid-control.service"
+SYSTEMD_PACKAGES = "${PN}"
+SYSTEMD_SERVICE_${PN} = "${SERVICE_FILE}"
+
+EXTRA_OECONF = " \
+  SYSTEMD_TARGET="multi-user.target" \
+       "
+
 FILES_${PN} = "${bindir}/swampd ${bindir}/setsensor"
 
 # The following installs the OEM IPMI handler for the fan controls.