phosphor-mapper: remove deprecated path whitelist

The c++ mapper implements dbus service whitelists in place of path
based whitelists.  Drop support for path whitelists.

Change-Id: I02820bb136f7aa76fd9c782df648455bd9fb7536
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/classes/phosphor-mapper.bbclass b/classes/phosphor-mapper.bbclass
index 97da850..3374a76 100644
--- a/classes/phosphor-mapper.bbclass
+++ b/classes/phosphor-mapper.bbclass
@@ -7,14 +7,11 @@
 # interfaces it will keep track of.
 #
 # The Phosphor layer by default configures the mapper to
-# watch xyz.openbmc_project services, interfaces and paths
-# only.  This configuration file is intended to be inherited
-# by native recipes in other layers that wish to add namespaces
+# watch xyz.openbmc_project services and interfaces only.
+# This configuration file is intended to be inherited by
+# native recipes in other layers that wish to add namespaces
 # or interfaces to the mapper watchlist.
 
-# Add path namespaces to be monitored:
-# PHOSPHOR_MAPPER_NAMESPACE_append = " /foo/bar"
-
 # Add service namespaces to be monitored:
 # PHOSPHOR_MAPPER_SERVICE_append = " foo.bar"
 
@@ -39,13 +36,11 @@
             with open(path, 'w+') as fd:
                 pass
 
-    process_var(d, 'PHOSPHOR_MAPPER_NAMESPACE', 'namespace_dir')
     process_var(d, 'PHOSPHOR_MAPPER_SERVICE', 'service_dir')
     process_var(d, 'PHOSPHOR_MAPPER_INTERFACE', 'interface_dir')
     process_var(d, 'PHOSPHOR_MAPPER_SERVICE_BLACKLIST', 'serviceblacklist_dir')
 }
 
-do_install[vardeps] += "PHOSPHOR_MAPPER_NAMESPACE"
 do_install[vardeps] += "PHOSPHOR_MAPPER_SERVICE"
 do_install[vardeps] += "PHOSPHOR_MAPPER_INTERFACE"
 do_install[vardeps] += "PHOSPHOR_MAPPER_SERVICE_BLACKLIST"